هدف اصلی افزونه‌ی المنتور ایجاد سریع‌ترین و پیشرفته‌ترین صفحات برای وردپرس است. در این مقاله الزامات سیستم مورد نیاز برای استفاده از المنتور ذکر شده است. (چنانچه از پشتیبانی سرور خود از امنتور مطمئن نیستید با هاست خود تماس بگیرید.)
وردپرس نسخه‌ی 5.0 یا بالاتر:
المنتور با وردپرس نسخه‌ی 5.0 یا بالاتر کار می‌کند.
نسخه‌ی 7 یا بالاتر:
توجه: اگر سایت شما از هاستینگی استفاده می‌کند که روی سرورهای با نسخه‌ی php پایین قرار دارد، ممکن است مشکلاتی را تجربه کنید. در این صورت پیشنهاد می‌شود که با شرکت ارائه‌کننده هاستینگ خود به منظور ارتقاء نسخه‌ی php تماس حاصل کنید.
المنتور ممکن است با نسخه php 5.4+ هم کار کند ولی به طور کلی نسخه‌های قدیمی به طور رسمی منسوخ شده‌اند، و به این ترتیب سایت شما در معرض آسیب‌پذیری‌ها و اشکالات امنیتی قرار می‌گیرد و ممکن است همیشه مطابق انچه که انتظار دارید کار نکند.
نسخه‌ی 5.6 یا بالاتر: شما به My SQL نسخه‌‌ی 5.6 یا بالاتر و یا Maria DB نسخه‌ی 10.0 یا بالاتر نیاز دارید.
محدودیت حافظه‌: حد حافظه WP، 128MB یا بیشتر (256MB یا بالاتر ترجیح داده می شود)
مرورگرها: برای ویرایش صفحات المنتور باید از مرورگرهای Firefox، Chrome یا Safari استفاده کنید. اگرچه از مرورگرهایی مانند Microsoft Edge و Microsoft Internet Explorer نمی‌توان برای ویرایش صفحات المنتور استفاده کرد اما توجه به این نکته که صفحات المنتور ساخته‌شده در مرورگرهای مدرن دقیقا به همان شکل در این مرورها نیز نمایش داده‌می‌شوند، حائز اهمیت است. اغلب ویژگی‌ها در اینترنت اکسپلورر به درستی نمایش داده می‌شوند اما به دلیل اینکه اینترنت اکسپلورر یک مرورگر قدیمی است ، از پشتیبانی برخی فناوری‌های مدرن وب که المنتور ممکن است از برخی آن‌ها استفاده کند، ناتوان است.
دستگاه: در حال حاضر امکان ویرایش صفحات با تلفن‌های همراه و تبلت‌ها وجود ندارد. فقط می‌توانید صفحات المنتور را در رایانه‌های رومیزی ویرایش کنید.
سرور: اگر وبسایت شما توسط WP Engine میزبانی می‌شود، به منظور جلوگیری از مشکلات احتمالی باید SSL را به وبسایت خود اضافه کنید.
به منظور جلوگیری از مشکلات ویرایشی و حملات مخرب احتمالی به سایت شما، از شرکت هاستینگ خود بخواهید که را روی گزینه‌ی یا اصل یکسان داشتن پیکربندی کند.
پسوند: بهتر است که پسوند PHP Z-lib را روی سرور خود فعال کنید. لطفاً از میزبان خود بخواهید که اگر این گزینه فعال نمی‌باشد، فرآیند فعالسازی آن را برای شما انجام دهد.
منبع: پیش‌نیازهای المنتور